Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

2000 MAZDA BJ5P 1500 AUTOMATIC CAR SUDDENLY GETTING STOP WHILE DRIVING.


Recommended Posts

Hi My friends,

I've bought a 2000 model, 2002 registered Mazda Familia BJ5P car before several days, unfortunately I got an issue,  it is while I'm driving car, engine getting suddenly stopped, it happens several times But the problem is cannot tell exact time for that issue.  Have you anyone had the same issue like this. please advice me.. still waiting..

 

 

Link to post
Share on other sites

You need to give more details since this could be due to 100s of factors. The only time I experienced a similar issue was on a B14 and the reason was a problem with the distributor. You mean the car stops suddenly and then you can immediately start again? What happens just before it stops? 

Edited by matroska
Link to post
Share on other sites

Thanks Matroska, actually this problem has occurred at the time i;m driving with lower speed , then I push accelerator padal but it is not getting accelerate and will stop the car. and after stop i should wait & see at least 15 min. without start  after that it will start.  

thanks. 

 

Link to post
Share on other sites

I'm sensing something in the sensor department. Could be the coil packs too. You don't get a check engine light when this happens?

Link to post
Share on other sites

Dear NRX,

I have checked the engine sensors with mechanic person also scanned the ECU. that all showing ok. but the problem is this car meter panel changed to diesel panel, therefore cannot see engine light but that coil mark is indicating sometimes and is off by automatically. anyhow now another electrician said need to check all the supply and wire harness connection to find out this stranger issue.now is going on,.is that anyone had this same experience too pls. share with me.i would like to get that info's for quickly fix this issue.. thanks to all.

Chamila.

Link to post
Share on other sites
11 hours ago, cham094 said:

Hi My friends,

I've bought a 2000 model, 2002 registered Mazda Familia BJ5P car before several days, unfortunately I got an issue,  it is while I'm driving car, engine getting suddenly stopped, it happens several times But the problem is cannot tell exact time for that issue.  Have you anyone had the same issue like this. please advice me.. still waiting..

 

 

You have bought this car recently. So I'm sure the seller knows the problem and most likely sold the car because of it. Call him/her up and ask him very nicely what the problem is (without getting in to an argument). Tell him you won't hold it against him but need to solve it.

If you knew the meter panel of this car has been changed, that too to a diesel panel, looks like you've landed a nice juicy lemon. Very rarely one would change the meter panel even if the car is old.

  • Like 3
Link to post
Share on other sites

According to your explanation the car seems to be suddenly stalling when you are driving at low speeds isn't it?
Is there any hesitation from the engine such as a vibration coming from the engine compartment when this happens? Or else does it suddenly stops without any indication and you would only notice it when you accelerate and the car does not move forward?
Engine stalling can occur due to many reasons as the other members have mentioned. Two major reasons applicable to the BJ series based on your explanations would be 

  • Issue with CAM position sensor
  • Worn out ignition coil packs

Usually above type of issues can be identified by an Engine scan done by a proper scanner.

However; what magnifies the issue in your scenario is that it seems that the car has been mishandled by someone before you purchased it.
Otherwise who will change the meter panel of a petrol car to a diesel car's meter panel. So; probably your car's electronics including the computer is already messed up and it may not show any error codes during the scanning. Are you comfortable with the competence of the electrician looking after the issue? Have you done any repairs with him before? Coz; its better to take it to someone competent before someone messes it up further.

  • Like 3
Link to post
Share on other sites

first thing first. does your CEL work (you might think that CEL works properly but it might have been wired to another indicator to just to turn off when the car is started).

If you are sure that CEL doesnt work (ex: it doesnt light when you turn the key to ignition position), then first thing is to rectify that.then you can perform  a self diagnostic test using the CEL.

if CEL doesnt work, then you have to find LED and a 1k (or up to 10k) resistor and perform the self diagnostic test.

you may refer this thread to get some idea about how to perform this test 

in your case TEN should be grounded, no need to use an LED if you are sure that CEL works, then CEL will emit the error code.

 

 

 

  • Like 1
Link to post
Share on other sites

I too suspect a faulty Ignition coil - the issue is that when you run the scan, the coils might be working fine, but when running it suddenly decides to give up

Has the petrol filter and pump been checked. ? Replacing  them at 100K is recommended.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...