Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

Recommended Posts

Dear All,

I'm having Suzuki SX4 2011 Japanese Model Sportsback (Not Sedan) Car.

There is an issue in this car with the Immobilizer.

When the key is turn to the ON position, the Immobilizer Bulb doesn't light up immediately. Accordingly, when the key is further turned for starting, the engine doesn't start. But after keeping the key in ON position for about 5 minutes, then light comes up. Then the engine can be started. 

If I start the engine and stop, and if I again turn the key to ON position, then the bulb comes up, and can be started. If the car is stopped for some time, then same issue comes up. (Waiting time for illuminating the immobilizer bulb is varied.)

I replaced the battery of the key, but the issue is still there.

Can someone help me in this regard?

Thanks.

Link to comment
Share on other sites

Dear John,

Thanks for the response.

This is a Key in Model. It's having 02 Lock/Unlock Buttons, need to insert the metal key to start.

Unfortunately, it's not a AWD. 😪

Thanks.

Link to comment
Share on other sites

Does every other option in the key work ? Like remote door locks have no issue ? 

It could be that the imobilizer transeivers itself are not working properly. 

Did you make any changes to any of the electronics in the car recently ? Install anything ? Remove anything ? 

Link to comment
Share on other sites

Dear iRage,

Yes, Lock & Unlock functions of the Key are working properly.

Recently, the Fuel Pump and the Fuel Pump Relay were replaced. I'm not sure whether this issue came before or after that replacement.

Thanks.

Link to comment
Share on other sites

Time changes lot. I measured the time with a stopwatch. Once it gave 1 min and 6 secs, and some times more than that and less than that. There is no rounded time like 1 min, 40 sec, 30 sec, etc.

Thanks.

Link to comment
Share on other sites

4 hours ago, Soh said:

Time changes lot. I measured the time with a stopwatch. Once it gave 1 min and 6 secs, and some times more than that and less than that. There is no rounded time like 1 min, 40 sec, 30 sec, etc.

Thanks.

may be worth check the ignition key barrel ???

regards

JC

Link to comment
Share on other sites

It could be the barrel, it could be the transeiver in the key or the car. Unless you are mechanically and/or electronically inclined I believe it will be a bit of a difficult task for you.  At the very most you can check if all the connections from the barrel are good.

Link to comment
Share on other sites

On 7/13/2021 at 8:10 PM, Soh said:

Thanks for the instruction.

But, how? What do I looking for? Can I do it by myself? Or should I have to go to a mechanic?

I don't think the visible inspection is possible to check the key barrel, may be once the key in the on position, try move the key up and down and try pull out and put back in (Make sure to NOT to use lot of force) See if you see any different in the time with the immobilizer light.

If the time changes when you try multiple times then most likely the key barrel. Your decision to consult the dealers would be the correct decision.  

regards,

JC

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

AutoLanka Cars For Sale

Post Your Ad Free [Click Here]



×
×
  • Create New...