Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

Car Stopped In The Middle Of The Road


DriverX
 Share

Recommended Posts

Hi Experts,

My case is a bit similar to an earlier case published by someone else. However there were no many helpful suggestions in that one I thought of opening a new case.e. My car (BJ5P)stopped on the middle of the road while driving, at the worst place possible. Halfway in the climb of the peliyagoda overhead bridge around 6pm friday. The car refused to start and after about half an hour it just started as if nothing happened. The temp sensor was not showing anything out of the ordinary.

I took it to David Pieris garage where I normally do my repairs and they said a camshaft sensor would need to be replaced. But before that they wanted to do a tuneup and see. However after two weeks yesterday after about a 20km drive I was not able to start the car for a while. I let it be for a while and again it started without any issue. How ever while driving sometimes I feel a sort of vibration/slowing down of the engine kinda thing happening and it gives me the chills.... :-( :unsure:

So now I wont to get this thing over with I am going to replace the cam sensor on monday. Any suggestions for this? Appriciate all the ideas.

Thanks in advance

Link to comment
Share on other sites

Hi Experts,

My case is a bit similar to an earlier case published by someone else. However there were no many helpful suggestions in that one I thought of opening a new case.e. My car (BJ5P)stopped on the middle of the road while driving, at the worst place possible. Halfway in the climb of the peliyagoda overhead bridge around 6pm friday. The car refused to start and after about half an hour it just started as if nothing happened. The temp sensor was not showing anything out of the ordinary.

I took it to David Pieris garage where I normally do my repairs and they said a camshaft sensor would need to be replaced. But before that they wanted to do a tuneup and see. However after two weeks yesterday after about a 20km drive I was not able to start the car for a while. I let it be for a while and again it started without any issue. How ever while driving sometimes I feel a sort of vibration/slowing down of the engine kinda thing happening and it gives me the chills.... :-( :unsure:

So now I wont to get this thing over with I am going to replace the cam sensor on monday. Any suggestions for this? Appriciate all the ideas.

Thanks in advance

Sounds like your fuel starvation to the engine as well ,either filter clogged up or the fuel cap valve is bad.

Edited by AL998
Link to comment
Share on other sites

Check your fuel pump and filters. Sounds like fuel starvation.

I had gunk in my tank once that needed a complete removal and washing. Symptoms were the same.

Next time it happens and if you are able to do so, open up the hood, track down the fuel hose that supplies fuel to the fuel rail, pull it off and get someone to crank the engine (Start). If no fuel spurts, that that could be your problem.

But check the coolant levels and all other usual suspects too.

Link to comment
Share on other sites

Sounds like your fuel starvation to the engine ,either filter clogged up or the fuel cap valve is bad.

This could be a possibility. BTW did you do the tune-up as suggested after the 1st incident? To see the full effect petrol/air filters change, spark plug clean, injector clean all needs to be done isn't it? Are you getting any "Engine check" errors?

Link to comment
Share on other sites

This could be a possibility. BTW did you do the tune-up as suggested after the 1st incident? To see the full effect petrol/air filters change, spark plug clean, injector clean all needs to be done isn't it? Are you getting any "Engine check" errors?

A busted pump will not give out a warning... its very rare. But if enough debris clogs up the filter engines tend to shut down.

What you can do is at home, pull out the rear seat and check the tank fuel pump which is under the seat. if you are careful you can slowly remove it and see for yourself.

Do not take any phones or any spark generating stuff inside the car and make sure its clean all around before you remove the tank cap.

Link to comment
Share on other sites

Hi Experts,

My case is a bit similar to an earlier case published by someone else. However there were no many helpful suggestions in that one I thought of opening a new case.e. My car (BJ5P)stopped on the middle of the road while driving, at the worst place possible. Halfway in the climb of the peliyagoda overhead bridge around 6pm friday. The car refused to start and after about half an hour it just started as if nothing happened. The temp sensor was not showing anything out of the ordinary.

I took it to David Pieris garage where I normally do my repairs and they said a camshaft sensor would need to be replaced. But before that they wanted to do a tuneup and see. However after two weeks yesterday after about a 20km drive I was not able to start the car for a while. I let it be for a while and again it started without any issue. How ever while driving sometimes I feel a sort of vibration/slowing down of the engine kinda thing happening and it gives me the chills.... :-( :unsure:

So now I wont to get this thing over with I am going to replace the cam sensor on monday. Any suggestions for this? Appriciate all the ideas.

Thanks in advance

Could you please elaborate more on this engine refuse to start. Is it freely cranking and not firing up or it's cranking as if there's excessive load on the starter motor ? Awaiting for the response to further diagnose.

Link to comment
Share on other sites

Hi Experts,

My case is a bit similar to an earlier case published by someone else. However there were no many helpful suggestions in that one I thought of opening a new case.e. My car (BJ5P)stopped on the middle of the road while driving, at the worst place possible. Halfway in the climb of the peliyagoda overhead bridge around 6pm friday. The car refused to start and after about half an hour it just started as if nothing happened. The temp sensor was not showing anything out of the ordinary.

I took it to David Pieris garage where I normally do my repairs and they said a camshaft sensor would need to be replaced. But before that they wanted to do a tuneup and see. However after two weeks yesterday after about a 20km drive I was not able to start the car for a while. I let it be for a while and again it started without any issue. How ever while driving sometimes I feel a sort of vibration/slowing down of the engine kinda thing happening and it gives me the chills.... :-( :unsure:

So now I wont to get this thing over with I am going to replace the cam sensor on monday. Any suggestions for this? Appriciate all the ideas.

Thanks in advance

I had a similar issue with my BJ5P about a month ago. It started to suddenly stop after driving for about 10-15 Kms on the road and refused to start. Only way i could re-start it was by allowing it to cool down for sometime. I did an engine scan and the culprit was the Cam sensor. Most probably you are facing the same issue. But make sure that your car computer is returning a faulty code for the Cam sensor before replacing it. i hope the guys at David pieris came to their conclusion after doing a proper scan right ? Otherwise it will be just a waste of money

Link to comment
Share on other sites

Could you please elaborate more on this engine refuse to start. Is it freely cranking and not firing up or it's cranking as if there's excessive load on the starter motor ? Awaiting for the response to further diagnose.

When the car refuses to start, it doesn't feel as if there's an excessive load. It freely cranks but wont start. Sometimes it starts for a few seconds but the engine is unable to keep going and it fails. When I depress or pump the accelerator during this still the engine does not speed up. It just goes very slow and stops.

A few months back while on my way to kandy, with the car fairly loaded it boiled at Kadugannawa and the engine light was on even after cooling down and restarting. I went to a local garage and they had a scanner. They guy got a code from the scanner which I donot remember now. But the description was something like " .... cam ...... discrimination......". He just reset it and said the engine has heated upto 110 Celsius. I dont know whether this has any bearing on what's happening now.

Thanks guys for the enthusiastic comments and suggestions given by all. I will have the garage check all these. Really appreciate the community feeling here. Any extra suggestions are welcome.

Thanks

Link to comment
Share on other sites

When the car refuses to start, it doesn't feel as if there's an excessive load. It freely cranks but wont start. Sometimes it starts for a few seconds but the engine is unable to keep going and it fails. When I depress or pump the accelerator during this still the engine does not speed up. It just goes very slow and stops.

A few months back while on my way to kandy, with the car fairly loaded it boiled at Kadugannawa and the engine light was on even after cooling down and restarting. I went to a local garage and they had a scanner. They guy got a code from the scanner which I donot remember now. But the description was something like " .... cam ...... discrimination......". He just reset it and said the engine has heated upto 110 Celsius. I dont know whether this has any bearing on what's happening now.

Thanks guys for the enthusiastic comments and suggestions given by all. I will have the garage check all these. Really appreciate the community feeling here. Any extra suggestions are welcome.

Thanks

sounds a weak fuel pump if thats the case, however what others said on crank sensor can be checked and considered.

Why i asked whether is there any resistant to start is to determine its due to excessive heat.

Link to comment
Share on other sites

Hi Experts,

My case is a bit similar to an earlier case published by someone else. However there were no many helpful suggestions in that one I thought of opening a new case.e. My car (BJ5P)stopped on the middle of the road while driving, at the worst place possible. Halfway in the climb of the peliyagoda overhead bridge around 6pm friday. The car refused to start and after about half an hour it just started as if nothing happened. The temp sensor was not showing anything out of the ordinary.

I took it to David Pieris garage where I normally do my repairs and they said a camshaft sensor would need to be replaced. But before that they wanted to do a tuneup and see. However after two weeks yesterday after about a 20km drive I was not able to start the car for a while. I let it be for a while and again it started without any issue. How ever while driving sometimes I feel a sort of vibration/slowing down of the engine kinda thing happening and it gives me the chills.... :-( :unsure:

So now I wont to get this thing over with I am going to replace the cam sensor on monday. Any suggestions for this? Appriciate all the ideas.

Thanks in advance

I too had same issue sometime back with my FB 15. It was the crank sensor & after replacing it I never had any similar issue..

Link to comment
Share on other sites

  • 4 weeks later...

Hi All,

First of all a big thank goes to everyone who pitched into help. For the benefit of all the cars suffering from the same issue as mine, I am posting the thing that worked for me.

After the last few engine stops I was dead scared to put the car on the road. I tried all sorts of re mediation such as, Engine tune up, Cleaning of fuel pump and fuel system,cleaning of air filter but none of them worked for me. At last I decided to change the Cam sensor. Took the car to a small garage and the guy there got me a cam sensor from one of his contacts.(This was a used one which was taken from an used engine sale) Cost me Rs. 6000 + 500 for the supply and installation. Its been more than 2 weeks now and looks like(fingers crossed) it had worked. But still when ever I get into heavy traffic my stress levels escalate :(:action-smiley-012:

DriverX

Link to comment
Share on other sites

Hi All,

First of all a big thank goes to everyone who pitched into help. For the benefit of all the cars suffering from the same issue as mine, I am posting the thing that worked for me.

After the last few engine stops I was dead scared to put the car on the road. I tried all sorts of re mediation such as, Engine tune up, Cleaning of fuel pump and fuel system,cleaning of air filter but none of them worked for me. At last I decided to change the Cam sensor. Took the car to a small garage and the guy there got me a cam sensor from one of his contacts.(This was a used one which was taken from an used engine sale) Cost me Rs. 6000 + 500 for the supply and installation. Its been more than 2 weeks now and looks like(fingers crossed) it had worked. But still when ever I get into heavy traffic my stress levels escalate :(:action-smiley-012:

DriverX

So, as i suspected, it was the cam sensor eh? Great to hear that you got your problem solved and thanks for sharing the final outcome. Many people who post questions here are not grateful enough to share the final outcome and often the threads go to a dead end. <_<

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

AutoLanka Cars For Sale

Post Your Ad Free [Click Here]



×
×
  • Create New...