Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

Car does not accelerate up hill


RaviH
 Share

Recommended Posts

I recently bought a 2007 Suzuki Swift (Japan beetle model) 1.3 cc Automatic car. My parking area is on a slope surface and every time when I start the car I need to climb a hill to hit the road. The problem is the car does not accelerate properly on that up hill surface. It's only an average hill surface. I slow down the car in the middle of the hill & tried with 'Low' gear, and even with that the car didn't move. I pushed accelerator but the RPM won't go above 2000.

But when I reverse car back to the parking area and accelerate at once, the car climbed the hill with speed. This issue only comes when I start the engine and tried to hit the road in that uphill area.  I tried replacing Auto Transmission Fluid, but the issue still is there.

I don't have much experience on driving and vehicle related stuff. Therefore, I want to know whether this is really a problem with the engine/gearbox or  this is usual in automatic cars. Dear members please help to sort out this.. Thank you.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

AutoLanka Cars For Sale

Post Your Ad Free [Click Here]



×
×
  • Create New...