Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

Mazda BJ5p - vvt engine - RS


mash1981
 Share

Recommended Posts

I ve been using this car for about an year now.suddnely this is giving some troubles.When on idle and ac is on car starts to jerk and drop rpm also car doesnt move though i hit the acceleration.

 

Any idea or a good place for a scan or inspection ?

 

Need experts advice

 

ThanksFB_IMG_1500361596254.jpg

Link to comment
Share on other sites

You have an elm adapter? If you do let me know, I will tell you what to do. 

Sounds like and issue in the maf or tps. Just remove the maf and see if the car runs fine. Maf is located between the air filer and throttle body, this is what it looks like:

mazda-3-maf-sensor-installed_normal.jpg

Link to comment
Share on other sites

most likely the MAF. had a similar issue with my BJ5W and turned out to be MAF. replacing would be better than trying to clean. 

Thanks bro.thinking of taking it to a mechanic on saturday.from where will i be able to buy a MAF?
Link to comment
Share on other sites

18 hours ago, mash1981 said:


Thanks bro.thinking of taking it to a mechanic on saturday.from where will i be able to buy a MAF?

MAF can be easily cleaned with an electronic cleaning aerosol fluid, It is a delicate,but a simple job.

If replace, should only  be replaced with a genuine one.

How about  throttle body cleaning !, You have to check that also.

Your car  fault attributes so many other factors too, such as the ignition system & spark plugs etc.

  • Like 1
Link to comment
Share on other sites

MAF can be easily cleaned with an electronic cleaning aerosol fluid, It is a delicate,but a simple job.
If replace, should only  be replaced with a genuine one.
How about  throttle body cleaning !, You have to check that also.
Your car  fault attributes so many other factors too, such as the ignition system & spark plugs etc.

Thanks.recently i did a tune up.Throttle body was cleaned at that time.shall ido a full scan first?im clueless where to start?
Link to comment
Share on other sites

Idling issues in a BJ5P can occur due to several reasons; Some of the reasons i can think of are as follows;

  • Issue with the MAF sensor
  • Issue with the CAM position sensor
  • Busted Ignition coil packs
  • Busted spark plugs
  • Vacuum leaks
  • Loosened Air filter

Since you have done a tune up recently; your spark plugs must have been already checked. Therefore, i would suspect it would be related to something else.
I think the best thing would be to perform a scan first. Are you nearby colombo? if so; the best place to do this would be Mazna motors.
They might diagnose the issue by experience even without scanning. 

Edited by LashNeo
  • Like 1
Link to comment
Share on other sites

Just now noticed.. Am i seeing a loosened connection in the highlighted location? Can you please check on this first? might be a Vacuum leak. Just push the hose forward to fasten it.

FB_IMG_1500361596254.jpg.926d56b42f1314038bdb49944a0d74df.jpg

Edited by LashNeo
Link to comment
Share on other sites

Just now noticed.. Am i seeing a loosened connection in the highlighted location? Can you please check on this first? might be a Vacuum leak. Just push the hose forward to fasten it.
FB_IMG_1500361596254.jpg.926d56b42f1314038bdb49944a0d74df.jpg.1a14a3273e473939d47413b523553798.jpg


Nope it's not unplugged, there is a sponge on that hose. It's the hose to the carcoal cannister.
  • Like 2
Link to comment
Share on other sites

Do yourself a favor (Before taking your car to so-called Mazda experts, go to a Recon Spare Parts shop and get the part. Try to get the entire throttle body (Recon) and put everything back, It will cost you around 8K-10K for the throttle body with sensors. I believe it was VTCS valve or something. ZL-VE repair manual is a bitch to comprehend. 

Edited by similarnames
  • Thanks 1
Link to comment
Share on other sites

8 hours ago, similarnames said:

Do yourself a favor (Before taking your car to so-called Mazda experts, go to a Recon Spare Parts shop and get the part. Try to get the entire throttle body (Recon) and put everything back, It will cost you around 8K-10K for the throttle body with sensors. I believe it was VTCS valve or something. ZL-VE repair manual is a bitch to comprehend. 

Hmmm well thats a good advice

 

Link to comment
Share on other sites

On 7/28/2017 at 7:48 PM, The Stig said:

 


Nope it's not unplugged, there is a sponge on that hose. It's the hose to the carcoal cannister.

 

Yep. You are correct. It’s the sponge.  I honestly thought the hose was loose. This happened to me some time back. The car was stalling in the middle of the road suddenly. There was no hesitation from the engine but the engine was going off on idle from time to time. While taking a look under the hood noticed that this hose was loose and everything was back to normal once it was connected. I couldn’t recall that there was a sponge attached to the hose. After seeing your comment; looked at the hose in my car again and noticed that there was a sponge but it was slipped towards the other end. Probably the reason for the disconnection of the hose as it helps to grip the hose against the other hose near it.

Link to comment
Share on other sites

3 hours ago, mash1981 said:

Scanned it !!!!

MAF replaced!!!

Lets run and see.have a stable idle than before.

IMG_20170730_110655.jpg

@mash1981 Glad to hear that you sorted out the issue. How much did it cost for the MAF? 

  • Thanks 1
Link to comment
Share on other sites

  • 4 months later...
  • 2 weeks later...
On 28/12/2017 at 8:53 PM, Pradeeppw said:

I have a car auto.mazda bj5p

Now blinking hold light and  giar not funtion only 3 and not going od

 

Pls explan ..

 

 

 

 

Go to nilwala or mazna and check your gear box.did you scan the vehicle ?

Link to comment
Share on other sites

On 12/28/2017 at 8:53 PM, Pradeeppw said:

I have a car auto.mazda bj5p

Now blinking hold light and  giar not funtion only 3 and not going od

 

Pls explan ..

 

 

 

 

This is a most common fault on Mazda BJ. Probably due to filling of incorrect ATF fluid /poor maintenance etc. and sometimes need a replacement of the gear box.

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

AutoLanka Cars For Sale

Post Your Ad Free [Click Here]



×
×
  • Create New...