Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

  • 0

AC not working after driving after lockdown


Question

I am having Toyota Aqua 2012. 

 Due to lockdown I was not able to use my car for an about one month. But I have start the car twice a week and let run about 15 minutes. I have noted that AC is working at that time.

But when I drive the car(about 100 kms ) yesterday AC is not working completely. Only fan is working.

What could be the cause for this?

Can you please suggest good place to have a check on this?

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

check the AC compressor clutch, may be it does not engage. along with that the electricals related to the clutch, such as fuses and relays.

Is it the AC fan that is working or is it the AC blower, electricals such as fuses and clutch relating to it.

Also check the AC gas levels to identify any leakages. maybe it was persistently leaking little by little but all of the sudden you realized that the cooling is not enough since you suddenly started driving.

  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...