Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

Fb15 Battery Inidicator.


Pethum85
 Share

Recommended Posts

Hi ppl,

My father car which is a 99 model FB 15 was serviced at pitstop two weeks back and during the service they have mentioned that the alternator cable needs to be replaced. Then from the following day while driving the battery indicator poped up.. and after few seconds it switched off and this behavior is taking place frequently.

We replaced the alternator cable and the indicator dint pop up for some time and it started to show up from yesterday again. Whats hard to understand is that it the indicator stays on for very few seconds.

Please help me out here. What can be the issue?

Link to comment
Share on other sites

Now the issue can be the battery. If you ran without it being properly charged (the alternator cable being bad), then the battery might need to be replaced now.

You could get the battery checked by a battery selling spot, but usually they will say your current battery is bad, cause obviously it would lead to a sale.

If I were you, I would go to a reliable garage and get the battery and related gadgets checked. (I mean the alternator, cable, the belts etc.)

And I'm pretty sure our experts might have answered same / similar questions previously on this forum. Why don't you do a search?

Link to comment
Share on other sites

Now the issue can be the battery. If you ran without it being properly charged (the alternator cable being bad), then the battery might need to be replaced now.

You could get the battery checked by a battery selling spot, but usually they will say your current battery is bad, cause obviously it would lead to a sale.

If I were you, I would go to a reliable garage and get the battery and related gadgets checked. (I mean the alternator, cable, the belts etc.)

And I'm pretty sure our experts might have answered same / similar questions previously on this forum. Why don't you do a search?

:grinning-smiley-003:

Link to comment
Share on other sites

Hi mates,

Thanks a lot for the response. We did check the battery from the Thimibirigasyaya joint they said the battery is fine. Now after replacing the belt the garage bas sadi the alternator is doing fine.. Can this be an issue of a sensor?

I,m 90% sure the issue is with alternator. Go for car Electric/ Batery shop. Tell the issue to the mechanic. He'll get the alternator out. And he'll have to open it. There are 2 Pins which are very critical for the electeic supply. (I dont really know what those node are called.) Anyway those node has to be cleaned. (might b used sand paper) Then reinstall the alternator. This will solve ur issue.

Good Luck!

Link to comment
Share on other sites

Hi mates,

Thanks a lot for the response. We did check the battery from the Thimibirigasyaya joint they said the battery is fine. Now after replacing the belt the garage bas sadi the alternator is doing fine.. Can this be an issue of a sensor?

Buddy did u get the Alternator Belt tension checked ?

Loose belt will not charge the battery :)

Edited by kelum_wj
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

AutoLanka Cars For Sale

Post Your Ad Free [Click Here]



×
×
  • Create New...