Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 


sira
 Share

Recommended Posts

Dear Friends

I brought Demio 2001 (LA3WDW) last week.

I noticed a small issue today. After start and move the gear leaver in to D position ( with in 1 min time) , car  looks very lazy to move. if i accelerate hard, it move slowly and that time i saw "HOLD" indicator flashing on dash board. then i switch off  the engine and start it again .all issue was gone and car start running as normal. 

what could be the issue on this please. the previous owner said he change the ATF. do i need to do a valve body service ? 

some other issue i have found as below

1. when the engine is hot , the speed around 60 and then accelerate bit , i can hear spark knock  - detonation sound

2.  previous owner has not changed the T-belt and now car reached 120K mileage. at what mileage i should change the T belt

Please advice

 

Thank you

sira 

 

 

Link to comment
Share on other sites

Congrats on your new toy !:action-smiley-033:

 

1 Use a good quasynthetic ATF yes, it's cheaper tom change atf than to change you transmision.

2.check and replace timig kit.Belt replacement recomended at 5 years 100.000Km

only the Maz 2 has a chain.

Cheers!

Edited by Twin Turbo
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

AutoLanka Cars For Sale

Post Your Ad Free [Click Here]



×
×
  • Create New...