Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

  • 0

What Else To Be Done Pls Help


hatharasinghe
 Share

Question

Dear All,

i already started topic under Acceleration Delay and lot of discussion my again i just explain the matter i have KIA SPECTRA auto gear car YOM is 2001. My problem is the car is unable to start at firstime at morning after trying several time it start and even in day time park several hours and then again it cant start once.then the following done by mechanic

1.Engine tuneup

2.Replace Spark Plugs

3.checks coil and related things

Same time replace Air Filter then he told the matter is at fuel pump so first he checked it showed me dirt in filter then clean it but the problem remain same.Then Mechanic told there is a leakeges of fuel pump line so once stop the car petrol come back to the tank as pressure regulator is not working.then , he showed me ,close the return line close to the pressure regulator then it start one shot even keep 24hr it start one shot then he did

Replace followings

1.Fuel Pump cost 3620/=

2.Pressure regulator (Fuel Pump) Unfortunatly i had to buy from Company cost 7500/=

3.Filter Unit 3000/= (Not the filter comes with Fule pump)

4.Replace tubes 500/=

So finally i thought its ok but today morning its the same so im now in fedup and no idea what to do next pls help me to recover this matter already wasted more money.

Link to comment
Share on other sites

19 answers to this question

Recommended Posts

  • 0

Does sound like quite a bit of money already spent. Is the engine cranking ok? I think the first thing to do is get this mechanic back on the case and figure out if it is not a fuel injection issue. The problem is your problem is so obscure it's difficult to suggest something particularly in light of the work already done....

Link to comment
Share on other sites

  • 0

Dear Don,

The mechanic checked the crank and the thing is when the returning fuel line from filter to tank is closed then it starts one shot any time no any delay and then when its open again the same matter so mechanic told there may be small hole inside the fuel line and he replaced but the result same now he also have no idea and sorry i couldnt mention the early post he told there was a problem on starter motor ( he called mendis wheel and it was wornoff and magnett also not in good condition ) so replaced these parts also.now he has no exact answer and telling me to check ECU and to be reprogramme to do send to company but im not agree for this until sure the case is this.

Link to comment
Share on other sites

  • 0

Dear Don,

The mechanic checked the crank and the thing is when the returning fuel line from filter to tank is closed then it starts one shot any time no any delay and then when its open again the same matter so mechanic told there may be small hole inside the fuel line and he replaced but the result same now he also have no idea and sorry i couldnt mention the early post he told there was a problem on starter motor ( he called mendis wheel and it was wornoff and magnett also not in good condition ) so replaced these parts also.now he has no exact answer and telling me to check ECU and to be reprogramme to do send to company but im not agree for this until sure the case is this.

Ok, looks like your mechanic has run out of ideas. Well getting a diagnostic done is probably not a bad thing at this point, but these ECU's can't be reprogrammed. They can be reset but for that you don't need to go to the company.

If you can get the car started, take it to the company and tell them to run a diagnostic. Check the price with them first, it should only be about Rs. 2000

Then if you don't trust your mechanic, you can try mine. His name is Wasantha, and his garage is close to the railway crossing on Baseline road. I don't have his number but basically its on a road that goes by the canal on the Wanathamulla side. If you ask somebody close to the railway crossing they should know. The road is on your right (on the other side of the road) if you are heading towards the Kelaniya Bridge from Borella.

Link to comment
Share on other sites

  • 0

Dear Don,

Thanks for telling your garage sure i try and i know this place as one of my friend told me this place earlier and today morning i just check the diagnostic not at the company but there is a place at kelaniya but no error msg code appear they told nothing error it costs 1200 so it seems still this is a mechanical or elctrical matter not electronic so once i free go this place the thing is still no direct answer.

Link to comment
Share on other sites

  • 0

dear Don , i live at Kiribathgoda but until first of Nov i at Badulla - Office Work

Ok, you have 2 options I think. But before both I do suggest you get the diagnostic done from the agent. That is because the factory diagnostic equipment gives a more detailed report than a generic scanner.

Then you can either take it to Komisiripala's mechanic Indika who sounds quite good or to Wasantha and see if they can sort you out. Only thing about Wasantha is insist on buying the spares you need yourself else he will buy it and mark it up.

Link to comment
Share on other sites

  • 0

Dear MkX , when i try to start the car its almost start but stops after 3 or 4 times then it start and normal so i think crank rotates and the mechanic telling for longtime parking there is a leak at somewhere either fuel pump or pressure regulator or else and all fuel return to fuel tank and thats why have to try several time until fuel come to engine but he couldnt fix the prob.

Dear Don, sure i try first Vasantha then Indika so hope end of this month i do it normally i get use to pay the bill not finding parts so its easy.

Link to comment
Share on other sites

  • 0

Dear MkX , when i try to start the car its almost start but stops after 3 or 4 times then it start and normal so i think crank rotates and the mechanic telling for longtime parking there is a leak at somewhere either fuel pump or pressure regulator or else and all fuel return to fuel tank and thats why have to try several time until fuel come to engine but he couldnt fix the prob.

Dear Don, sure i try first Vasantha then Indika so hope end of this month i do it normally i get use to pay the bill not finding parts so its easy.

Yes, but the problem you describe are usually associated with carburetor engines. In fuel injection, the fuel pump will send a feed of fuel to the injector rail, so there is usually no delay in fuel getting to the engine. If your compression and spark plugs are ok the car will start on the first crank. I mean you can see for yourself, if you get a clean bucket, take the fuel horse from the injector line off, put it inside the bucket and put the ignition to on position (don't try to start). The fuel pump will start up (you will here the noise from the back) and fuel will come rushing out of the pipe. Now leaks, problems with the fuel regulator, a blocked breather valve in the fuel tank can all cause problems with this process, and hopefully you will find the issue soon.

Link to comment
Share on other sites

  • 0

Dear MkX , when i try to start the car its almost start but stops after 3 or 4 times then it start and normal so i think crank rotates and the mechanic telling for longtime parking there is a leak at somewhere either fuel pump or pressure regulator or else and all fuel return to fuel tank and thats why have to try several time until fuel come to engine but he couldnt fix the prob.

Dear Don, sure i try first Vasantha then Indika so hope end of this month i do it normally i get use to pay the bill not finding parts so its easy.

This is where I have little doubt. Does fuel ignite? Can you observe RPM goes up, Dashboard lights off .. and then engine stop again? or no fuel ignite at all??

Link to comment
Share on other sites

  • 0

Dear Don, MkX,

Finally ,did the diagonastic test at Company, told me there is a problem at Air flow censer and ignition coil unit and sometime its doesnt take current correctly than i replaced both , Air flow censer 14500 and Ignition coil unit 9500 and now no problems one shot start and pickups and all really good so i think i replaced all untis from one end to other .Thanks for your helps.

Link to comment
Share on other sites

  • 0

Dear Don, MkX,

Finally ,did the diagonastic test at Company, told me there is a problem at Air flow censer and ignition coil unit and sometime its doesnt take current correctly than i replaced both , Air flow censer 14500 and Ignition coil unit 9500 and now no problems one shot start and pickups and all really good so i think i replaced all untis from one end to other .Thanks for your helps.

Glad you got it sorted. Seems like their diagnostic was correct!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

AutoLanka Cars For Sale

Post Your Ad Free [Click Here]



×
×
  • Create New...