Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

High Coolant Temperature Warning


nish1
 Share

Recommended Posts

Every morning when I start my car it show me this high coolant tem warning..? why is it?

Probably because your car is overheating. Does it only appear on first start or does it appear all the time? Either way you should get that checked out by a competent mechanic....

What is your car?

Edited by Supra_Natural
Link to comment
Share on other sites

Probably because your car is overheating. Does it only appear on first start or does it appear all the time? Either way you should get that checked out by a competent mechanic....

What is your car?

its start at every start and couple of minutes its disappears..

Edited by nish1
Link to comment
Share on other sites

Wait, are you sure its the overheat indicator? My car doesn't have a temp gauge, only two indicators to indicate cold engine and over heating. The cold engine indicator (blue) stays lit for a minute or two after starting till the engine reaches operating temperature.

Link to comment
Share on other sites

Could just be an initialization thing? I've seen cars that snap the tacho and speedo to max and revert to normal on start up.

That's the POST routine for electronic stepper motor driven analog gauges. Never gets old, watching those needles dance.

Link to comment
Share on other sites

If it's a 1st gen Vitz, the instrument cluster is very similar to my Vios (the Vios uses the Vitz RS cluster), so you have two temp indicators, blue and red. The blue one lights up right after a cold start and stays lit for a minute or two till the engine warms up. Once warmed up it turns off. It's the same with the newer models as well.

Link to comment
Share on other sites

The vitz has 2 coolant temperature warning lights, one green (low coolant temp) and one red (high coolant temp) . Both come on when you turn on the ignition key. The red one should go off a second or two after starting but the green one may stay until the engine has warmed up to the normal operating temperature. If the RED comes on while the engine is running you are in trouble. Stop immediately and get expert help.

Link to comment
Share on other sites

The vitz has 2 coolant temperature warning lights, one green (low coolant temp) and one red (high coolant temp) . Both come on when you turn on the ignition key. The red one should go off a second or two after starting but the green one may stay until the engine has warmed up to the normal operating temperature. If the RED comes on while the engine is running you are in trouble. Stop immediately and get expert help.

Good One...I have never experienced the red indication but all the time I get the green when ignition on..So that's mean I'm safe..Ha Ha Ha.. Thanks Buddy..

Link to comment
Share on other sites

  • 4 years later...

Hi guys,

Dragged this old thread to sort of overheating problem in my Wife's car march AK12.

When drive very slowly in a traffic or stop for sometime engine running with AC on, red lights comes. Coolant level is ok and fans are working. We bought this month ago doesn't much of history of her and can somebody suggest what to do? Odometer is genuine 61K.

Thanks

 

 

Link to comment
Share on other sites

9 hours ago, whmsujith said:

Hi guys,

Dragged this old thread to sort of overheating problem in my Wife's car march AK12.

When drive very slowly in a traffic or stop for sometime engine running with AC on, red lights comes. Coolant level is ok and fans are working. We bought this month ago doesn't much of history of her and can somebody suggest what to do? Odometer is genuine 61K.

Thanks

 

 

Although fans are working, are they working at high speed? Dual speed fans need to work at high speed when AC is on. 

Link to comment
Share on other sites

4 hours ago, Davy said:

Although fans are working, are they working at high speed? Dual speed fans need to work at high speed when AC is on. 

Thanks for your reply Davy.

I am not sure whether it works at correct speed. Let me know how to check DIY or should I take her to a mechanic?

Link to comment
Share on other sites

if fans are working properly (proper speed), then this might be due to the clogged Radiator or (this can be due to clogged AC condenser ) . "clogged"  means not a block in internal coolant lines, it is just dust accumulated outside.

just clean the radiator (and AC condenser) might solve the problem.

is your AC works properly at idle?


 

Link to comment
Share on other sites

Well if you do not know much history of the car how come you are so confident that the mileage is genuine - just my curiosity. BTW if a AK12 has run only 61k kms on its odo, it must have been idling for most of the days. Do you see rusty deposits (muddy color) in the fill up tank. In that case it can be due to water pump's propeller gone rusty due to long idle period. However, check the external things first as others have suggested above first.

Link to comment
Share on other sites

4 hours ago, MV-5 said:

if fans are working properly (proper speed), then this might be due to the clogged Radiator or (this can be due to clogged AC condenser ) . "clogged"  means not a block in internal coolant lines, it is just dust accumulated outside.

just clean the radiator (and AC condenser) might solve the problem.

is your AC works properly at idle?


 

Ok, I also thought so. AC works normally at idle, but anyway the coolness of the airflow is not enough like in my other cars, is it also related to this issue?

Link to comment
Share on other sites

2 hours ago, Rumesh88 said:

Well if you do not know much history of the car how come you are so confident that the mileage is genuine - just my curiosity. BTW if a AK12 has run only 61k kms on its odo, it must have been idling for most of the days. Do you see rusty deposits (muddy color) in the fill up tank. In that case it can be due to water pump's propeller gone rusty due to long idle period. However, check the external things first as others have suggested above first.

Yes, since it was used by a lady most of the time it had been idle since it has been registered with KM plates in Dec 2010 with ODO is 19k as she said. All the service records were available but only major services like full services.

I will check the color and let you know tomorrow; now I am far away.

Link to comment
Share on other sites

4 hours ago, whmsujith said:

Ok, I also thought so. AC works normally at idle, but anyway the coolness of the airflow is not enough like in my other cars, is it also related to this issue?

yes, it is related in many ways. but here, the the relationship is the setup. AC condenser and radiator are placed in very close to each other and in lot of cars AC condenser is located in front of the radiator. anyway same air flow will be used to cool down both.

if AC condenser or radiator clogged, even though fan works properly there is a huge resistance to this air flow.then both elements will not function as the way we expect.

ultimate result is a heating problem, or cool air will not blow through the AC vent or both.

NOTE: when there is a heating problem due to other reason (just like low coolant or tiny leak in head gasket) , still that may negatively affect on AC system because then radiator is warmer than the normal condition.you can imagine that now system has to cool down two elements which is located very closely but one element is warmer than the expected level. so it affects to the other element.

     

Edited by MV-5
Link to comment
Share on other sites

  • 3 weeks later...
On 4/30/2017 at 5:57 AM, Davy said:

Although fans are working, are they working at high speed? Dual speed fans need to work at high speed when AC is on. 

 

On 4/30/2017 at 11:15 AM, MV-5 said:

if fans are working properly (proper speed), then this might be due to the clogged Radiator or (this can be due to clogged AC condenser ) . "clogged"  means not a block in internal coolant lines, it is just dust accumulated outside.

just clean the radiator (and AC condenser) might solve the problem.

is your AC works properly at idle?


 

Didn't have any time till today for attend this. Took her to radiator repair shop and checked.

Both of you were correct, fan was the issue, replaced the fan motor with recon one. In the process cleaned the radiator as well, there was clogging inside. Ran about 25 kms with AC on, so far no issue. 

By the way technician told that previous owner has removed thermostat valve, is it to run without this? Pls advise.

Thanks.

Link to comment
Share on other sites

Thermostat valve blocks water flow from engine to radiator until the engine has reached the optimal operating temperature range. It's removal will make the engine operate cooler and less fuel efficient.more relevant for cold countries. Btw did you check the radiator lid for damage,leaks?

Link to comment
Share on other sites

9 hours ago, whmsujith said:

By the way technician told that previous owner has removed thermostat valve, is it to run without this? Pls advise.

Thanks.

That's the makabass way of circumventing radiator/fan issues. Have an original thermostat installed because it is there for a reason.

Link to comment
Share on other sites

11 hours ago, ajm said:

Thermostat valve blocks water flow from engine to radiator until the engine has reached the optimal operating temperature range. It's removal will make the engine operate cooler and less fuel efficient.more relevant for cold countries. Btw did you check the radiator lid for damage,leaks?

Yes, Checked it,there is no damage Or leaks found.

 

3 hours ago, Rumesh88 said:

That's the makabass way of circumventing radiator/fan issues. Have an original thermostat installed because it is there for a reason.

Noted with thanks. I will get installed one soon. Where can I find a original one from? 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

AutoLanka Cars For Sale

Post Your Ad Free [Click Here]



×
×
  • Create New...