Jump to content
  • Welcome to AutoLanka

    :action-smiley-028: We found you speeding on AutoLanka Forums without any registration! If you want the best experience, please sign in. Safe driving! 

  • 0

Lancer C12, Gurgling sound during hard acceleration


Iced-T
 Share

Question

Hi All,

Seasons Greetings!

When accelerating hard on gear 3 onwards ... I get a gurgling sound from the engine bay...only when the sound goes off the car starts to pick up ... if i slowly press the accelerator there is no sound and the car accelerates normally  ... what could it be?

There is no black smoke.

Iced-T

Link to comment
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Hi all.. thanks for all ur help... The problem was with a cracked vacuum hose from the air inlet filter to the exhaust manifold area in the engine (not attached to the carb). 

I am so glad I managed to find this. After the hose replacement no hesitation at all xD. 

I checked the ends of the hose, whereas the middle of the hose was cracked... cant believe i missed this . 

 

Edited by Iced-T
Link to comment
Share on other sites

  • 0

Fuel starvation ? or engine-miss ? do you have the following symptoms:

- Upon cold start, if you try to drive the car, you feel bit of a power lag? and it runs smoothly after couple of KM's of when the engine is heated properly?

- During cold start do u feel any engine miss?

Link to comment
Share on other sites

  • 0
20 minutes ago, PerfMad said:

Fuel starvation ? or engine-miss ? do you have the following symptoms:

- Upon cold start, if you try to drive the car, you feel bit of a power lag? and it runs smoothly after couple of KM's of when the engine is heated properly?

- During cold start do u feel any engine miss?

I do not have any engine miss during cold start or running, engine is very smooth... On idle It revs without any hesitation.

In gear 1 and 2 i get the full power band even during cold starts.  I have not noticed any power lag on these gears. 

How do I check if there is fuel starvation? 
 

 

 

Edited by Iced-T
Link to comment
Share on other sites

  • 0
25 minutes ago, Iced-T said:

I do not have any engine miss during cold start or running, engine is very smooth... On idle It revs without any hesitation.

In gear 1 and 2 i get the full power band even during cold starts.  I have not noticed any power lag on these gears. 

How do I check if there is fuel starvation? 
 

 

 

Well you have the answer in your explanation.. If there is a fuel starvation mainly it idles poorly during cold start and during the first KM's u feel the power lag when you try to accelerate.. bcz these were few common issues even when i was using my lancer CB.. However issue vanished after cleaning the carb..

 

When was the last time you did a tuneup? if you are getting the required power during 1-2 gears, then its difficult to think that there is a fuel starvation issue even.. could be an ignition issue may be..

I'm sort of out of clues on this machan... over to experts who have experience on the same matter cz i just shared mine :)  

Link to comment
Share on other sites

  • 0
18 minutes ago, PerfMad said:

Well you have the answer in your explanation.. If there is a fuel starvation mainly it idles poorly during cold start and during the first KM's u feel the power lag when you try to accelerate.. bcz these were few common issues even when i was using my lancer CB.. However issue vanished after cleaning the carb..

 

When was the last time you did a tuneup? if you are getting the required power during 1-2 gears, then its difficult to think that there is a fuel starvation issue even.. could be an ignition issue may be..

I'm sort of out of clues on this machan... over to experts who have experience on the same matter cz i just shared mine :)  

Its a 4G15 Carb.... I havent done a tune up in ages. But the carburetor has been cleaned with those carb cleaning products. 

Thanks for ur help. Its much appreciated :)  

Link to comment
Share on other sites

  • 0
9 minutes ago, Iced-T said:

Its a 4G15 Carb.... I havent done a tune up in ages. But the carburetor has been cleaned with those carb cleaning products. 

Thanks for ur help. Its much appreciated :)  

i had a 4G13.. However i prefer you do do proper tuneup from a good person like (Mr. Dammika fernando) and may be he will point you to correct path to resolve the issue.

 

I sent coupls of my friends who had lancer carb models with poor idling and fuel consumption issues and they are really happy with the end result. And this fellow has alot of related leads to get things done related to carbs as well. Therefore I hope you'll be able to resolve the issue, or atleast find the root cause..

 

Cheers..

  • Like 1
Link to comment
Share on other sites

  • 0

Sounds like pre-ignition knock. There can be many reason for this ranging from bad fuel, lean air/fuel mixture, wrong ignition timing, bad spark plugs, insufficient fuel pressure and carbon deposits in the intake and carburetor. a proper inspection needs to be done to determine the actual cause. 

Didn't your car have a gearbox issue a few weeks ago? Was that sorted and was the correct transmission fluid used? Did this ignition issue happen immediately after the gearbox repair? Just trying to figure out if the mechanic messed up the transmission which thereby causes it to put an extra load on the engine.

Also remember that it could be driving style as well. If you are in a hurry to shift to the next gear before reaching the correct minimum speed for the next gear, pre-ignition knock maybe heard. 

Link to comment
Share on other sites

  • 0
13 minutes ago, Davy said:

Sounds like pre-ignition knock. There can be many reason for this ranging from bad fuel, lean air/fuel mixture, wrong ignition timing, bad spark plugs, insufficient fuel pressure and carbon deposits in the intake and carburetor. a proper inspection needs to be done to determine the actual cause. 

Didn't your car have a gearbox issue a few weeks ago? Was that sorted and was the correct transmission fluid used? Did this ignition issue happen immediately after the gearbox repair? Just trying to figure out if the mechanic messed up the transmission which thereby causes it to put an extra load on the engine.

Also remember that it could be driving style as well. If you are in a hurry to shift to the next gear before reaching the correct minimum speed for the next gear, pre-ignition knock maybe heard. 

Hi Davy,

Yes... I put in a reconditioned gearbox, flywheel, new clutch plate, new pressure plate and put in all the required bushes washers ... pretty much everything that needs to be done.

I am using ceypetco 90 transmission fluid oil.

To avoid the acceleration lag.. i accelerate more on the 2nd gear and shift to third, and then I balance my driving style so that the gurgling sound doesnt come. But overtaking is becoming an issue.

The problem slowly developed after the gearbox replacement. It was very gradual. 

Could it be related? 

Edited by Iced-T
Link to comment
Share on other sites

  • 0
51 minutes ago, Iced-T said:

Its a 4G15 Carb.... I havent done a tune up in ages. But the carburetor has been cleaned with those carb cleaning products. 

Thanks for ur help. Its much appreciated :)  

Well that's a "bothal carb" in local jargon. It could be that it's piston movement is somewhat restricted. Was it cleaned with the unit disassembled or just by spraying from top? If it is the latter method then there is every chance that the linear bearing is contaminated.

There has been many discussions on 4G15 carbs, Just search the forum with string "bothal carb".

Edited by Rumesh88
  • Like 1
Link to comment
Share on other sites

  • 0
14 minutes ago, Iced-T said:

Hi Davy,

Yes... I put in a reconditioned gearbox, flywheel, new clutch plate, new pressure plate and put in all the required bushes washers ... pretty much everything that needs to be done.

I am using ceypetco 90 transmission fluid oil.

To avoid the acceleration lag.. i accelerate more on the 2nd gear and shift to third, and then I balance my driving style so that the gurgling sound doesnt come. But overtaking is becoming an issue.

The problem slowly developed after the gearbox replacement. It was very gradual. 

Could it be related? 

Well, since you seem to have done a proper gearbox replacement, I guess we can safely assume that it's not related. 

Knowing @Rumesh88's knowledge on carbs, I think your best bet is to follow his advice. Cleaning the carburettor followed by a proper "tuning" should sort out your issue.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

AutoLanka Cars For Sale

Post Your Ad Free [Click Here]



×
×
  • Create New...